Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

Encounter duration timer refresh instability

Hello,
I have set main table update frequency and mini parse update interval to 1 second. The encounter timer still keeps jumping from 1 to 3 seconds while I need the timer to be updated every second.

Any idea how to solve this?

I use only ACT + FFXIV plugin, no overlays. Unfortunately playing in borderless always kills my FPS so I prefer just having ACT on 2nd monitor.
Tagged:

Comments

  • edited July 2019
    There are two things.
    If there is not enough CPU resources to update quick enough, the UI timer that updates the GUI will get pushed back.  It's not a critical timing system.
    The encounter length is a duration of the current encounter's actions.  If there are no actions for 5 seconds, the encounter duration does not increase during those seconds.
  • edited July 2019
    The first option is more likely. Is there something I can do about it? Apart from getting a better CPU. Ironically the timer itself is the most important thing for me (together with triggers).

    Do you think that giving ACT higher priority in task manager could affect this (EDIT: Didn't help)?
    Or is there a way to turn some other ACT functions off to ease the CPU strain?
  • There would have to be considerable CPU stress to cause the first one, I think.

    Any method of prioritizing the GUI would likely impact whatever else is using CPU, such as the game?  But your edit says you have tried that.

    In the Options tab of ACT, there is a Show Performance Wizard button which will guide you through most settings that can affect CPU and memory usage of ACT.


  • edited July 2019
    So, I have changed the performance settings (I restarted ACT so now before/after is the same) and at this moment the CPU strain should be arround 60% lesser than it was. The problem still persists though. With nothing else than ACT and FFXIV running any resource (CPU/disc/memory) doesn't get over 40% in task manager.

    EDIT: Also, is there a way to make miniparse not stop showing encounter duration timer while enemy is untargetable? At this moment it stops when boss jumps out (5:20 for example) and then continues once boss is targetable by skipping certain amount of time (so it starts to go from 5:40 onwards). It doesnt start a new encounter, just temporarily stops counting time.


  • EQAditu said:
    {...}
    The encounter length is a duration of the current encounter's actions.  If there are no actions for 5 seconds, the encounter duration does not increase during those seconds.
    Hyskaris said:
    {...}
    EDIT: Also, is there a way to make miniparse not stop showing encounter duration timer while enemy is untargetable? At this moment it stops when boss jumps out (5:20 for example) and then continues once boss is targetable by skipping certain amount of time (so it starts to go from 5:40 onwards). It doesnt start a new encounter, just temporarily stops counting time.
    {...}
    There is not.  The encounter duration is calculated, not counted.  If there are no combat actions to add to the encounter, the calculation will not change.  You can allow "heals" to extend encounter duration, but that's not really the same thing.
Sign In or Register to comment.