Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics.

[Bug] Using -minimize argument while "Minimize ACT to a tray icon" causes crash on load

I didn't see a github linked, so I thought I'd post here.

As the topic says - If I have "Minimize ACT to a tray icon" checked and close ACT, it will crash every time I try to launch it with the "-minimize" argument. Turning off "Minimize ACT to a tray icon" lets it load minimized, but not to a tray icon. I assume it's because it shouldn't ever be minimized, but then is because of the argument.

A feature request while I'm here, if possible: The behavior I'm after is the program launching silently - Ideally, no pop up dialog boxes (loading settings), no UI, just started straight to the tray. 

Thanks for the program, and keep up the good work :)
Tagged:

Comments

  • This touches on a hard to avoid bug in the .NET Framework where completely hiding the Windows Form before it ever shows up will somehow cause a StackOverflowException.  It doesn't seem to happen if it just starts minimized or if it starts normally then self-minimizes.  That commandline argument is a loophole that I forgot about.  I previously tried to delay hiding the form if it was in the config file, but I bet that argument is still causing the bug.

    I've never used Github for ACT.  Technically ACT has been around longer than Github and I didn't feel right about using their platform.  They want open source projects whereas ACT has never been officially open sourced.
  • Unfortunately, I cannot reproduce this.  When I run ACT with Minimize set in the shortcut and -minimize set in the command line, the main ACT window appears for a second and then disappears... but doesn't crash.

    I tried putting the -minimize logic before and after config load and it made it completely silent for me(in tray-icon), but I understand not showing at all is what causes the crash for some people.  Using the -minimize flag circumvents the haphazard crash mitigation I put in for people who experience it.  It seems you're one of those people that experiences that crash condition still.


Sign In or Register to comment.