Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

ACT X64 crashing on "creating window" startup

I got a problem that when I open up my ACT specificaly the x64 version, it stays in the "creating window" step for about 2-3 seconds, then closes without any warning or message.
This problem happened all of a sudden, I was using it fine for months but it started happened again yesterday (I had this problem once before, although i have no idea how i fixed it)
I can open the x86 version just fine, but it doesnt parse at all since it cant find a running FFXIV game
I tried deleting all config files on \AppData\Roaming\Advanced Combat Tracker, tried to reinstall several times, deleting plugins, fresh installs, restarting PC multiple times, disabling anti virus, firewall, doing sfc /scannow, still nothing seems to work.

Tagged:

Comments

  • edited August 2019

    First, a crash like that would be logged in the Windows Event Viewer (Application log, Application Error and .NET Runtime sources both).  See if you can find a stacktrace or exception message/code.

    Second, if you run ACT with the  -debug command-line switch, it will log more about where it was during startup.  Remove the old error log in AppData and run ACT with the debug switch and I'll be able to tell more about where it was based off of that.

  • I digged around a bit on windows event viewer, and the expection code should be: 0xc0000005


    as for the act error log (with and without the -debug line), i get only one line:

    Application-Start 2019-08-26T22:11:32 (v3.4.1     Release: 261 | .NET v4.8+ (528040) | OS Microsoft Windows NT 10.0.18362.0) 74


  • Okay, so it starts making the Windows Forms, but never gets to initializing the main ACT form and logging anything interesting.

    How far would you say the progress bar made it for you?  For example, this is one tick:


    # for hex 0xc0000005 / decimal -1073741819 :
      STATUS_ACCESS_VIOLATION                                       ntstatus.h

    Meaning, it tried to touch something that it wasn't allowed to.  Hard to say if that was a file or what.

    In the Event Viewer, there's no .NET Runtime line directly below the Application Error line?  I guess super hard crashes might not.



  • It doesnt even start ticking, it just stays at creating windows for 3 seconds with no progress, then immediately closes
    also I dont see anything related to .net runtime on event viewer, although its my first time actually using event viewer, so maybe I missed something.

    BUT, while I was waiting for a reply I googled the exception error, and after a few failed attempts, I came cross this solution: navigate through the registry editor and find HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_Dlls, then setting the value of LoadAppInit_DLLs from 0 to 1 and then restarting my computer seems to fixed it, since Im now able to execute ACT properply

  • I looked at three different computers and it was already 0x1 for each of them.  I can't imagine what turned it off for you.  I've never heard of it except in the context of Sysinternals Autoruns' AppInit tab, which is usually empty.

Sign In or Register to comment.