Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

Getting FFXIV 90002 & 2002 errors when running latest ACT

As the topic states, I'm trying to run ACT, but whenever I start it up while already ingame, I get a 90002 connection error. And when I try to log back in, while ACT is running, I get a lobby error 2002. I have tried looking online to see if there's a solution, but the closest solution I could find is from 5 years ago, and with the updates to ACT, it's no longer a viable solution. (The solution was to disable Parsing from Network Data, but this doesn't seem to be an option any longer in the FFXIV Plugin).


I'm really at a loss as to what to do, or why this is happening, as I've never had it happen before. ACT and FFXIV worked for me just fine up until Patch 5.2.

Tagged:

Comments

  • People in Discord are saying that Avast Firewall is an issue.  With Avast disabled, the connection remains stable.

  • Yeah, except ACT is an allowed program, so, Avast shouldn't be creating any problems with it. Even after a fresh install of ACT, I keep getting the 2002 error. Never had any issues before.

    And I don't want to complete disable Avast. I'm afraid of getting hacked or worse.

  • I'm just telling you what others have found out.  In actuality, it is probably SquareEnix's fault when patch 5.2 is combined with Avast and ACT.  You will have zero success telling SquareEnix to fix the issue and may even receive an official warning against you.  Meaning you can only get Avast to fix the issue(or stop using them).  Good luck getting Avast to listen to such an edge-case.

    A random guess is that Avast is messing up when ACT is receiving the raw network traffic and perhaps prevents FFXIV from receiving the same traffic.  I don't know how a game patch would cause that, but SquareEnix has been adding random process flags in their patches to "prevent"(discourage) other processes from interacting with it.  Mostly those efforts have been minor challenges for the community, but they show SquareEnix is messing with things... and a patch creating your issue is not a surprise.

    Your only other choice is to try WinPCap mode in the plugin and install a bridge like NpCap.  No telling what Avast will do with that network capture method as it is messing Network mode up already.

  • Well, if there's no other solutions other than switching from Avast or going PCap, I guess I can't use ACT anymore.

  • ...have you even tried to see if WinPCap mode fixes your issue?  Not to mention, did you even try to see if disabling Avast actually helps or not?  If you're unwilling to experiment, then yes... you're not going to get any solution.

    Random firewalls and VPNs are outside of what the plugin author wants to deal with.  I don't think they will be looking at the Avast issue as it was only reported by 3 people or so.

  • I was having this issue. Works with avast firewall off and windows firewall on.

  • edited May 22

    Anyone with this issue...  please try WinPCap Network mode in the parsing plugin and install Npcap.  So far no one is willing to try and report back. 😛

    https://nmap.org/npcap/dist/npcap-0.9991.exe
    Default settings are fine, check the 2nd checkbox if you always run ACT as Admin and want extra security.





  • edited May 22
    EQAditu said:

    Anyone with this issue...  please try WinPCap Network mode in the parsing plugin and install Npcap.  So far no one is willing to try and report back. 😛

    https://nmap.org/npcap/dist/npcap-0.9991.exe
    Default settings are fine, check the 2nd checkbox if you always run ACT as Admin and want extra security.




    I just wanted to let you know I was having the same issue, Npcap worked perfectly! Thanks!


Sign In or Register to comment.