Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

Having issues with ACT spell timers and custom triggers

Hi all, I am new to custom triggers/spell timers/ and overlays and could use some help. I followed a youtube video on how to create a custom trigger with tts to call out when the timer was about to end. The first trigger I set up worked perfectly when I tested it. I went in to make a second one and there doesn't appear to be a way to make a new one it seems you basically click on the current one and change the names and text then hit add/edit and it makes the new one for you. I set up the spell timer for the second one basically the same way. Went to test and neither timer worked. It didn't show the spell timer or play the tts. When I right click on the spell timer window to open the configuration part I get an unhandled exception cannot access a disposed object error  now. I can only right click on the spell timer window once to get it to open. After that I get the error every time and I have to close act and reopen it to get into the spell timer configuration window.

 I tried deleting the triggers and recreating them didn't help.  I tried using different names when I recreated them didn't help. 

I shut the pc down for a couple minutes to try and clear memory didn't help. 

I completely uninstalled and reinstalled act didn't help. No trigger I create does anything and if I try to right click the spell timer window more then once I get 

that same error.

I checked the sound options in both window 10 and act and they seem to be properly set. I can hear the sounds when I test from within that window.

 I have a picture of the error if it would help. 

Any idea what I did am doing wrong? 


  • edited July 2020

    Custom Triggers are individualized by their Category and Regex.  If you don't change either of these, you are editing.  If you change either, you're adding a new individual trigger.  If you require two triggers with the same Regex, simply change the Category.

    Spell Timers are similar with the Category and Spell Name.

    It's hard to tell, but trying to make the second trigger might have been too confusing and you might have modified it so that neither was working.  You don't have to click an existing trigger to make a new one but you can do so if you want to have some of the fields pre-filled for you.

    The thing about the Spell Timer options panel is a bug that appeared when for some reason the [x] unattached itself from the code I wanted it to run.  The [x] is supposed to hide the window, but when unattached it simply destroys the window and it cannot be shown again.  The same thing happened to the Updater window last ACT version.  Seems like a Visual Studio bug that randomly detaches event-handlers when you open the window in the designer.

    The work around is to close the window the same way you opened it.  Right-click the timer panel.  Do not click the [x].
  • Thank you for getting back to me I appreciate it.

    They were all different abilities they shared similar fields so I just changed the regex and tab name. I had them all under the category skills. Should they be in different categories? 

    Ok so it is a bug then, thanks. What I found was that if I closed act and reopened it after adjusting each trigger they seemed to work normally, but if I tried to do one then another then another and just go test they didn't work at all. Is it intended to need to close act after creating a trigger?

  • I don't really know what it is you're seeing.  The changes should be applied as soon as you edit them.  Anything shown in the treeview is real-time.  If they're highlighted green, they should be active.

Sign In or Register to comment.