Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

Exception error message help

edited September 27 in General ACT Discussion

Have just installed ACT on a new computer and attempted to copy over old plug-ins and triggers. Am now getting 'Exception removing or checking frame data' System.NullReferenceException: frames[1] was null .... and a whole lot more.

Am essentially an ACT newbie who copies triggers I'm given and this is preventing some of my triggers from working properly. Would greatly appreciate suggestions on what to check/fix. If it matters, am using it for EQ2 and have several plugins as well as many dozens of triggers that I have accumulated over the years.

Tagged:

Comments

  • Spell Timers having issues won't affect Custom Triggers from working unless the Custom Trigger was starting a Spell Timer.

    This is the first report of it happening: https://forums.advancedcombattracker.com/discussion/175/spell-timers-keep-stopping

    The exception logging you're seeing is from ACT detecting this problem.  As I cannot reproduce it, I cannot fix it except to suppress the error from breaking the Spell Timers window.  That's what those logged exceptions mean, it's suppressing one of the symptoms of the issue.  Again, I cannot reproduce this issue, so I cannot fix the cause.

    The exception message specifically means it tried to render two Spell Timers, but #2 didn't have data to read.  Since the data is null, it can't even say which Spell Timer is the cause.
  • Thanks for the fast response.  I will try to pay more attention next time and actually include the log file since you seem willing and able to see what I've done. 

  • I've looked at the code again and tried to suppress the symptom earlier on... so it completely deletes the timer with null data instead of hiding it from displaying.  But why a timer with null data gets added, I have no idea.  The Spell Timers section of code is very old and hasn't had issues for years.

Sign In or Register to comment.