Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Cannot use ACT at all, "Configuration system failed to initalize"

edited March 30 in General ACT Discussion
No matter what I've tried, I cannot get ACT to work. I'm trying to set it up for FFXIV.

I'm running 64-bit Windows 10 Home with the latest 64-bit ACT, here's every error I encounter:
When starting ACT, a pop-up appears with the title "Version check failed" and message "Unable to obtain version info from the web. Configuration system failed to initalize."
Pressing OK, I then try to add ravahn's FFXIV plugin and receive the following pop-up with no title and the message "An error occurred whilst updating plugin. The error message was: An exception occurred during a WebClient request."
Pressing OK, the plugin was appears in the list, but its description is another message: "FFXIV Plugin Startup Failed: System.Configuration.ConfigurationErrorsException: Configuration system failed to initalize --> System.Configuration.ConfigurationErrorsException: Unrecognized configuration section runtime (C:\Program Files (x86)\Advanced Combat Tracker\Advanced Comba [...])."

Looking into C:\Windows\Microsoft.NET\Framework and C:\Windows\Microsoft.NET\Framework64, both have one folder with the version "v4.0.30319".

In ACT's folder, "Advanced Combat Tracker.exe.config" has the following contents: https://hastebin.com/docabehixi.xml (here's "ACTx86.exe.config" too, https://hastebin.com/neyadeguwo.xml).

The program cannot do anything internet related without erroring about the WebClient. I've tried disabling Windows Firewall and resetting my /etc/hosts file, to no avail.

If I'm missing any crucial information, please let me know.

Thanks for your hard work!


Tagged:

Comments

  • Sounds like the .NET Framework is fairly corrupted in some way.

    A simple Google search says you should run "sfc /scannow" to fix it.

    Odd that it's the second time I'm suggesting it this week, despite it never fixing anything for me personally.
  • Tried for a few hours to fix the corruption, but I'll admit defeat and reinstall Windows.

    Thanks for your help, and for pointing me in the right direction. :)
  • Hmm, that really is defeated. Did none of the solutions listed on that page help?
  • Nope, unfortunately not. I messed around with a lot of DISM, chkdsk, and SFC. My Windows was very outdated and I had removed some registry files relating to .NET in an attempt to fix it before writing to the forums, it's very likely that it was my fault. ;)

    This is the price I pay for my stupidity, but it's a good lesson nonetheless!
Sign In or Register to comment.