Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

If requesting help, make sure to mention what game you are attempting to use ACT with.
For the best FFXIV support, join Ravahn's Discord Server. Also check out ngld's FFXIV FAQ for starter diagnostics. Lastly, Jojo's setup guide.

/s in custom trigger does not paste into EQ2

/s in a custom trigger is not pasting into EQ2

<Trigger R="looks for\s(.){3}\s+most hated" SD="Cast bulwark now" ST="3" CR="F" C=" General" T="F" TN="" Ta="F" />

pastes as

<Trigger R="looks for(.){3}+most hated" SD="Cast bulwark now" ST="3" CR="F" C=" General" T="F" TN="" Ta="F" />


Comments

  • So what you're saying is that EQ2 is considering \s an escape sequence similar to \aITEM and will prevent the chat from containing it to prevent spoofing?

    I'm trying to understand why you have a regex like this to begin with.  Is \s really necessary to use instead of an actual space?  How come you're capturing a single character into "group 1" three times when the first and second time is discarded?
  • (.){3} catches its, his, her

    I can probably use spaces instead of \s but ACT still doesn't handle \s like in

    <Trigger R="[bB]alanced\s+[sS]ynergy" SD="Balanced synergy" ST="3" CR="F" C="Spells" T="T" TN="Balanced Synergy" Ta="F" />

    A space can not be used since multiple spaces can/do show up.


  • " +"(space-plus) is completely valid for a regex.  It sees the single space the same as any other literal character and will repeat the search one-to-many times(greedy).  Same for " *" and " ?".

    Secondly, "(.){3}" has needless complexity as well.  ".{3}" is sufficient here and will avoid the overhead of using capturing groups.

    If you absolutely must group characters together, I suggest using a non-capturing group like so: "(?:its|his|her)" instead of "(its|his|her)".

    ACT sometimes has to process lines thousands of times a second and the more efficient your regular expressions are, the better for CPU usage.

    I can try adding single backslashes to the XML entities escape list, but you don't need to wait for that if you modify your custom triggers.  Do word boundary anchors(\b) and other regex escape sequences also have this problem, or just "\s"?
  • (?:its|his|her) worked. Thanks.

    \b did paste.
Sign In or Register to comment.